To use Izly from the mobile application you need to have a smartphone with an Internet connection; Android 2.2/Windows phone 8/iOS 7.0 for iPhone are the minimum version required. Phones must be equipped with at least a 3G connection.

To use Izly from the Izly website’s personal space you must connect from a computer or a tablet with an Internet connection and from the following browsers

  • Safari (all versions)

  • Opéra (all versions)

  • Chrome (all versions)

  • Firefox (all versions)

  • Internet 8 (IE8) and above

Did this answer your question?